Is Smart Slider 3 compatible with PHP 7?

Yes, it is.

I run a PHP compatibility check using a 3rd party plugin, and it highlighted some problems. Does that mean the slider isn't fully compatible?

Smart Slider 3 is compatible with PHP version 5.4 and above. Because of the changes in PHP, we have compatibility codes for 5.x and 7.x as well, which only run on these PHP versions. Unfortunately, plugins don't check if a code runs on a certain PHP version only, but simply look through the files and check for certain words/codeparts, so they often report false positive results.

From version 3.3.22 the minimum PHP requirement of Smart Slider 3 is 5.6.20!

Some of the false positives include:

1

*Filename: wp-content/plugins/nextend-smart-slider3-pro/nextend/library/libraries/localization/pomo/streams.php*
Warning
21 \| WARNING \| INI directive 'mbstring.func_overload' is deprecated since PHP 7.2

This code only runs on PHP 5.x

2

*Filename: wp-content/plugins/nextend-smart-slider3-pro/library/smartslider/plugins/generator/facebook/Facebook/PseudoRandomString/McryptPseudoRandomStringGenerator.php*
Error
52 \| ERROR \| Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead 52 \| ERROR \| Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead 52 \| ERROR \| The constant MCRYPT_DEV_URANDOM is deprecated since PHP 7.1 and removed since PHP 7.2

This code only runs on PHP 5.x