Other extension/plugin doesn't work, when Smart Slider is published

Some extensions have errors, but they seem as if they work just fine, until another code is published too, because of the different loading order, and the error handling of the browser. You can try to figure out the issue with Firebug, but most errors are caused, because some other code has failed before it in this extension/plugin, which can be hard to track down, and the fix you find in google might be just a half solution. For the developers of that code it can be much easier to find out the real cause of the problem, so you should rather update that extension/plugin first, and then if it doesn't help, contact them, not us, because we don't support other people's extensions.