Does Smart Slider 3 support Magento 2?

No, we are not supporting Magento 2, because currently it has bigger caching problems related to extensions. We sent a ticket to them about the issue, but haven't got a reply. This was quite a while ago, so it doesn't looks like they are planning to resolve this problem. Until that would happen, we cannot develop for Magento 2 properly, so currently we are not planning on creating a compatible version for Magento 2.